SonarQube, Visual Studio Online

Creating a Service Endpoint in Visual Studio Online fails with “User does not have required permissions for the service endpoint”

Today I was adding another (generic) Service Endpoint to Visual Studio Online in order to integrate one of our Team Projects with SonarQube. This Service Endpoint is the link that describes how the Build should connect to SonarQube. While creating it I got an error “User does not have required permissions for the service endpoint”

Service Endpoint Permissions - Error Message

Although I thought I had enough permissions, it didn’t seem to be the case. I found out that I need to not only be member of “Endpoint Administrators”, but also of “Endpoint Creators”. By default, as a Team Project Administrator, one is member of the “Endpoint Administrators” group, but not of the “Endpoint Creators” group. So I put myself in the correct group and voila; it worked;

Service Endpoint Permissions - Groups

Advertisements

One thought on “Creating a Service Endpoint in Visual Studio Online fails with “User does not have required permissions for the service endpoint”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s